Creates an instance of the DeleteElements resolution.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static FailureResolution Create( Document document, ElementId id ) |
Visual Basic |
---|
Public Shared Function Create ( _ document As Document, _ id As ElementId _ ) As FailureResolution |
Visual C++ |
---|
public: static FailureResolution^ Create( Document^ document, ElementId^ id ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document which owns the element to delete.
- id
- Type: Autodesk.Revit.DB..::..ElementId
The id of the element that will be deleted when this resolution is chosen.
Return Value
The instance of the DeletedElements resolution.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The input id is not valid for deletion. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |