Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public FamilyInstanceCreationData NewFamilyInstanceCreationData( Face face, XYZ location, XYZ referenceDirection, FamilySymbol symbol ) |
Visual Basic |
---|
Public Function NewFamilyInstanceCreationData ( _ face As Face, _ location As XYZ, _ referenceDirection As XYZ, _ symbol As FamilySymbol _ ) As FamilyInstanceCreationData |
Visual C++ |
---|
public: FamilyInstanceCreationData^ NewFamilyInstanceCreationData( Face^ face, XYZ^ location, XYZ^ referenceDirection, FamilySymbol^ symbol ) |
Parameters
- face
- Type: Autodesk.Revit.DB..::..Face
A face of a geometry object.
- location
- Type: Autodesk.Revit.DB..::..XYZ
Point on the face where the instance is to be placed.
- referenceDirection
- Type: Autodesk.Revit.DB..::..XYZ
A vector that defines the direction of the family instance.
- symbol
- Type: Autodesk.Revit.DB..::..FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.