Creates a filter rule that determines whether double-precision values
from the document are less than a certain value.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static FilterRule CreateLessRule( ElementId parameter, double value, double epsilon ) |
Visual Basic |
---|
Public Shared Function CreateLessRule ( _ parameter As ElementId, _ value As Double, _ epsilon As Double _ ) As FilterRule |
Visual C++ |
---|
public: static FilterRule^ CreateLessRule( ElementId^ parameter, double value, double epsilon ) |
Parameters
- parameter
- Type: Autodesk.Revit.DB..::..ElementId
A double-typed parameter used to get values from the document for a given element.
- value
- Type: System..::..Double
The user-supplied value against which values from the document will be compared.
- epsilon
- Type: System..::..Double
Defines the tolerance within which two values may be considered equal.
Remarks
Values less than the user-supplied value but within epsilon
are considered equal, not less.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The given value for value is not finite -or- The given value for value is not a number -or- The given value for epsilon is not finite -or- The given value for epsilon is not a number |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |