Gets the local coordinate system (LCS) that reflects analytical model orientation at the specified parameter value along a curve.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2015
Syntax
C# |
---|
public Transform GetLocalCoordinateSystem(
double parameter
) |
Visual Basic |
---|
Public Function GetLocalCoordinateSystem ( _
parameter As Double _
) As Transform |
Visual C++ |
---|
public:
Transform^ GetLocalCoordinateSystem(
double parameter
) |
Parameters
- parameter
- Type: System..::..Double
The parameter value along a curve that should be in the range [0, 1], where 0 represents start and 1 represents end of the element.
Return Value
Transformation matrix.
- x - longitudinal axis,
- y - transversal, section - horizontal, strong axis,
- z - transversal, section - vertical, weak axis,
- origin - base point of LCS.
Exceptions
See Also