Adds The CurveElements to one or more FaceRegions.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static void AddCurvesToFaceRegion( Document document, IList<ElementId> curveElemIds ) |
Visual Basic |
---|
Public Shared Sub AddCurvesToFaceRegion ( _ document As Document, _ curveElemIds As IList(Of ElementId) _ ) |
Visual C++ |
---|
public: static void AddCurvesToFaceRegion( Document^ document, IList<ElementId^>^ curveElemIds ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The Document.
- curveElemIds
- Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
The ElementIds of CurveElements which are to define the FaceRegion.
Remarks
The CurveElements that are input may produce an arbitrary number of regions.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | All the input CurveElements must be CurveByPoints, with the sketchOnSurface attribute set to True, and for each CurveElement, the defining ReferencePoints must be hosted on References related to a common Face or Edge. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Failed to add curves to FaceRegion. |