The rule type for this demand factor definition.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public ElectricalDemandFactorRule RuleType { get; set; } |
Visual Basic |
---|
Public Property RuleType As ElectricalDemandFactorRule Get Set |
Visual C++ |
---|
public: property ElectricalDemandFactorRule RuleType { ElectricalDemandFactorRule get (); void set (ElectricalDemandFactorRule value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |