The offset of the start of the extrusion relative to the sketch plane.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public double StartOffset { get; set; } |
Visual Basic |
---|
Public Property StartOffset As Double Get Set |
Visual C++ |
---|
public: property double StartOffset { double get (); void set (double value); } |
Remarks
The direction of the offset is based on the normal of the extrusion's sketch
plane: a positive value is in the direction of the normal, a negative value is in the
other direction.