Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShape.
Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public void AppendShape( IList<GeometryObject> pGeomArr, DirectShapeTargetViewType viewType ) |
Visual Basic |
---|
Public Sub AppendShape ( _ pGeomArr As IList(Of GeometryObject), _ viewType As DirectShapeTargetViewType _ ) |
Visual C++ |
---|
public: void AppendShape( IList<GeometryObject^>^ pGeomArr, DirectShapeTargetViewType viewType ) |
Parameters
- pGeomArr
- Type: System.Collections.Generic..::..IList<(Of <(<'GeometryObject>)>)>
Shape expressed as a collection of GeometryObjects. For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve. For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve.
- viewType
- Type: Autodesk.Revit.DB..::..DirectShapeTargetViewType
Passing DirectShapeTargetViewType.Default as view type will cause the default shape to be appended.
Remarks
The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be
joined with the appended geometry. It is up to the caller to ensure that the combination of geometry
will have the correct appearance in Revit.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | At least one member of pGeomArr does not satisfy DirectShape validation criteria. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |