The type of rebar distribution(also known as Rebar Set Type).
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public DistributionType DistributionType { get; set; } |
Visual Basic |
---|
Public Property DistributionType As DistributionType Get Set |
Visual C++ |
---|
public: property DistributionType DistributionType { DistributionType get (); void set (DistributionType value); } |
Remarks
The possible values of this property are:
- Uniform
- VaryingLength
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |