Checks whether or not the structural analysis is enabled, and enable or disable it.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public bool IsStructuralAnalysisEnabled { get; set; } |
Visual Basic |
---|
Public Property IsStructuralAnalysisEnabled As Boolean Get Set |
Visual C++ |
---|
public: property bool IsStructuralAnalysisEnabled { bool get (); void set (bool value); } |
Remarks
When structural analysis is disabled the structural analytical model will not be updated
automatically by Revit. Enabling structural analysis will not take effect unless the structure discipline is also enabled.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The current product type is not ProductType.Revit and discipline controls are not enabled. |