Determines if there is a matching RebarPresentationMode for the current set of selected hidden and unhidden bars assigned to the given view.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public RebarPresentationMode FindMatchingPredefinedPresentationMode( View dBView ) |
Visual Basic |
---|
Public Function FindMatchingPredefinedPresentationMode ( _ dBView As View _ ) As RebarPresentationMode |
Visual C++ |
---|
public: RebarPresentationMode FindMatchingPredefinedPresentationMode( View^ dBView ) |
Parameters
- dBView
- Type: Autodesk.Revit.DB..::..View
The view.
Return Value
The presentation mode that matches the current set of selected hidden and unhidden bars. If there is no better match, this returns RebarPresentationMode.Select.
Remarks
If the presentation mode is not PresentationMode.Select for the view, this function returns the current mode.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |