Returns Ids of the currently active application-level servers registered for the service.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public IList<Guid> GetActiveServerIds() |
Visual Basic |
---|
Public Function GetActiveServerIds As IList(Of Guid) |
Visual C++ |
---|
public: IList<Guid>^ GetActiveServerIds() |
Return Value
A set of GUIDs of the application-wide active servers; the list may be empty.
Remarks
More than one application-level server can be active at a given time in a multi-server service,
but it is possible that no server is active (unless the service is mandatory).