Check integrity of content documents of all families loaded in the host document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static bool CheckAllFamiliesSlow(
Document ADoc,
ISet<ElementId> corruptFamilyIds
) |
Visual Basic |
---|
Public Shared Function CheckAllFamiliesSlow ( _
ADoc As Document, _
corruptFamilyIds As ISet(Of ElementId) _
) As Boolean |
Visual C++ |
---|
public:
static bool CheckAllFamiliesSlow(
Document^ ADoc,
ISet<ElementId^>^ corruptFamilyIds
) |
Parameters
- ADoc
- Type: Autodesk.Revit.DB..::..Document
The host document.
- corruptFamilyIds
- Type: System.Collections.Generic..::..ISet<(Of <(<'ElementId>)>)>
Return ids of families that need to be reloaded because their content documents are missing or corrupt.
Return Value
Returns true if all content documents are usable.
Remarks
Exceptions
See Also