Gets the default Divided Surface number for a fixed number layout for U or V gridlines.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public int GetSurfaceNumber( UVGridlineType gridlines ) |
Visual Basic |
---|
Public Function GetSurfaceNumber ( _ gridlines As UVGridlineType _ ) As Integer |
Visual C++ |
---|
public: int GetSurfaceNumber( UVGridlineType gridlines ) |
Parameters
- gridlines
- Type: Autodesk.Revit.DB..::..UVGridlineType
U-gridlines or V-gridlines.
Return Value
The default number for a fixed number layout.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |