A filter used to pass curve elements which are of a specific type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public class CurveElementFilter : ElementSlowFilter |
Visual Basic |
---|
Public Class CurveElementFilter _ Inherits ElementSlowFilter |
Visual C++ |
---|
public ref class CurveElementFilter : public ElementSlowFilter |
Examples

// Create a CurveElement filter to find CurveByPoints elements. // It is necessary to use the CurveElementFilter, and not an ElementClassFilter or the shortcut // method OfClass() because subclasses of CurveElement are not supported by those methods. CurveElementFilter filter = new CurveElementFilter(CurveElementType.CurveByPoints); // Apply the filter to the elements in the active document FilteredElementCollector collector = new FilteredElementCollector(document); ICollection<Element> founds = collector.WherePasses(filter).ToElements(); // Find all curve elements: use inverted filter with invalid CurveElementType to match elements CurveElementFilter notCurveByPntFilter = new CurveElementFilter(CurveElementType.Invalid, true); // inverted filter collector = new FilteredElementCollector(document); ICollection<Element> notCurveByPntFounds = collector.WherePasses(notCurveByPntFilter).ToElements();

' Create a CurveElement filter to find CurveByPoints elements. ' It is necessary to use the CurveElementFilter, and not an ElementClassFilter or the shortcut ' method OfClass() because subclasses of CurveElement are not supported by those methods. Dim filter As New CurveElementFilter(CurveElementType.CurveByPoints) ' Apply the filter to the elements in the active document Dim collector As New FilteredElementCollector(document) Dim founds As ICollection(Of Element) = collector.WherePasses(filter).ToElements() ' Find all curve elements: use inverted filter with invalid CurveElementType to match elements Dim notCurveByPntFilter As New CurveElementFilter(CurveElementType.Invalid, True) ' inverted filter collector = New FilteredElementCollector(document) Dim notCurveByPntFounds As ICollection(Of Element) = collector.WherePasses(notCurveByPntFilter).ToElements()
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..CurveElementFilter
Autodesk.Revit.DB..::..ElementFilter
Autodesk.Revit.DB..::..ElementSlowFilter
Autodesk.Revit.DB..::..CurveElementFilter