Creates a non rectangular profile wall within the project using the default wall type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static Wall Create(
Document document,
IList<Curve> profile,
bool structural
) |
Visual Basic |
---|
Public Shared Function Create ( _
document As Document, _
profile As IList(Of Curve), _
structural As Boolean _
) As Wall |
Visual C++ |
---|
public:
static Wall^ Create(
Document^ document,
IList<Curve^>^ profile,
bool structural
) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document in which the new wall is created.
- profile
- Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
An array of planar curves that represent the vertical profile of the wall.
- structural
- Type: System..::..Boolean
If set, specifies that the wall is structural in nature.
Return Value
If successful a new wall object within the project.
Exceptions
See Also