The number of middle supports used in the stair.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public int MiddleSupportsNumber { get; set; } |
Visual Basic |
---|
Public Property MiddleSupportsNumber As Integer Get Set |
Visual C++ |
---|
public: property int MiddleSupportsNumber { int get (); void set (int value); } |
Field Value
0 if the stairs type has no middle support.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for supportsNumber is negative. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The stairs type has no middle support so the data being set is not applicable. |