Creates a new orthographic 3D assembly view for the assembly instance.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static View3D Create3DOrthographic( Document document, ElementId assemblyInstanceId ) |
Visual Basic |
---|
Public Shared Function Create3DOrthographic ( _ document As Document, _ assemblyInstanceId As ElementId _ ) As View3D |
Visual C++ |
---|
public: static View3D^ Create3DOrthographic( Document^ document, ElementId^ assemblyInstanceId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document to which the view will be added.
- assemblyInstanceId
- Type: Autodesk.Revit.DB..::..ElementId
Id of the assembly instance that owns the new view.
Return Value
A new orthographic 3D assembly view.
Remarks
The view will have the same orientation as the Default 3D view.
The document must be regenerated before using the 3D view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | assemblyInstanceId is not an AssemblyInstance. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction. |