Adds a macro to the module.
Namespace: Autodesk.Revit.DB.MacrosAssembly: RevitAPIMacros (in RevitAPIMacros.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2014
Syntax
C# |
---|
public Macro AddMacro(
string name,
string description,
string code
) |
Visual Basic |
---|
Public Function AddMacro ( _
name As String, _
description As String, _
code As String _
) As Macro |
Visual C++ |
---|
public:
Macro^ AddMacro(
String^ name,
String^ description,
String^ code
) |
Parameters
- name
- Type: System..::..String
The macro name.
- description
- Type: System..::..String
The description.
- code
- Type: System..::..String
The code string, which should be the lines between the main bounding brackets of a method.
Return Value
The new macro.
Exceptions
See Also