Gets an AppearanceAssetElement by name.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static AppearanceAssetElement GetAppearanceAssetElementByName( Document doc, string name ) |
Visual Basic |
---|
Public Shared Function GetAppearanceAssetElementByName ( _ doc As Document, _ name As String _ ) As AppearanceAssetElement |
Visual C++ |
---|
public: static AppearanceAssetElement^ GetAppearanceAssetElementByName( Document^ doc, String^ name ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
Document containing the AppearanceAssetElement.
- name
- Type: System..::..String
Name of the AppearanceAssetElement.
Return Value
The AppearanceAssetElement with the given name, or nullNothingnullptra null reference (Nothing in Visual Basic) if this element does not exist.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |