Associate a formula with the parameter.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2009
Syntax
C# |
---|
public void SetParameterFormula(
ElementId paramId,
string formula
) |
Visual Basic |
---|
Public Sub SetParameterFormula ( _
paramId As ElementId, _
formula As String _
) |
Visual C++ |
---|
public:
void SetParameterFormula(
ElementId^ paramId,
String^ formula
) |
Parameters
- paramId
- Type: Autodesk.Revit.DB..::..ElementId
Id of a parameter in the definition.
- formula
- Type: System..::..String
The formula expressed as a string. The string is exactly what a user would
type into the Family Types dialog, e.g. "Total Length*3.14159*(Bar Diameter/2)*(Bar Diameter/2)"
Exceptions
See Also