Removes member element ids from the mechanical equipment set.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019
Syntax
C# |
---|
public void Remove( ISet<ElementId> elemIds ) |
Visual Basic |
---|
Public Sub Remove ( _ elemIds As ISet(Of ElementId) _ ) |
Visual C++ |
---|
public: void Remove( ISet<ElementId^>^ elemIds ) |
Parameters
- elemIds
- Type: System.Collections.Generic..::..ISet<(Of <(<'ElementId>)>)>
Element ids to be removed from the mechanical equipment set.
Remarks
If all the members are removed, the instance of the mechanical equipment set is automatically deleted.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | One or more element ids was not permitted to be removed from the mechanical equipment set. All elements should be a member of the mechanical equipment set. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |