Enum represents severity of a failure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public enum FailureSeverity |
Visual Basic |
---|
Public Enumeration FailureSeverity |
Visual C++ |
---|
public enum class FailureSeverity |
Members
Member name | Description |
---|---|
None | Represents a failure-free state of a document. This value cannot be used as an argument to construct FailureMesasage. |
Warning | Failure that can be ignored by end-user. Failures of this severity do not prevent transactions from being committed. |
Error | Failure that cannot be ignored. If FailureMeassage of this severity is posted, the current transaction cannot be committed unless failure is resolved via appropriate FailureResolution. |
DocumentCorruption | Failure that forces Transaction to be rolled back as soon as possible due to known corruption to a document. When failure of this severity is posted, reading of information from a document is not allowed. The current transaction has to be rolled back first in order to work with the document. |