The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2011
Syntax
C# |
---|
public bool CheckGroundPlane(
ElementId groundPlaneId
) |
Visual Basic |
---|
Public Function CheckGroundPlane ( _
groundPlaneId As ElementId _
) As Boolean |
Visual C++ |
---|
public:
bool CheckGroundPlane(
ElementId^ groundPlaneId
) |
Parameters
- groundPlaneId
- Type: Autodesk.Revit.DB..::..ElementId
The element id to be checked to confirm that it is suitable to be a ground plane (i.e., that it is a level) or
that it is invalidElementId. Setting ground plane with invalidElementId will lead to the ground plane being "reset".
Return Value
True if the input element is a level or invalidElementId, false otherwise.
Exceptions
See Also