Sets the reference pick.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void SetReferencePick( Reference referencePick ) |
Visual Basic |
---|
Public Sub SetReferencePick ( _ referencePick As Reference _ ) |
Visual C++ |
---|
public: void SetReferencePick( Reference^ referencePick ) |
Parameters
- referencePick
- Type: Autodesk.Revit.DB..::..Reference
The pick to set.
Remarks
It is suggested to get the new reference via GetNumberSystemReference() from the host element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The referencePick is not a valid reference. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |