Create a non-periodic Hermite surface using a net of 3D points as input.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public static HermiteSurface Create( int nU, int nV, IList<XYZ> points ) |
Visual Basic |
---|
Public Shared Function Create ( _ nU As Integer, _ nV As Integer, _ points As IList(Of XYZ) _ ) As HermiteSurface |
Visual C++ |
---|
public: static HermiteSurface^ Create( int nU, int nV, IList<XYZ^>^ points ) |
Parameters
- nU
- Type: System..::..Int32
Number of points in U direction.
- nV
- Type: System..::..Int32
Number of points in V direction.
- points
- Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
Array of points. Must contain nU*nV points.
Return Value
A Hermite surface object created from input data.
Remarks
Points form a net of nU * nV 3D points. Suitable defaults will be used for other surface parameters.
See other Create() functions if greater control over input is desired.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | Thrown when the input arguments are inconsistent. The most common case is incorrect number of items in one of the lists. |