Create a reference point at a given location in an Autodesk
Revit family document.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public ReferencePoint NewReferencePoint( XYZ A_0 ) |
Visual Basic |
---|
Public Function NewReferencePoint ( _ A_0 As XYZ _ ) As ReferencePoint |
Visual C++ |
---|
public: ReferencePoint^ NewReferencePoint( XYZ^ A_0 ) |
Parameters
- A_0
- Type: Autodesk.Revit.DB..::..XYZ
Return Value
The newly created ReferencePoint.
Remarks
The ReferencePoint will have a default coordinate system
corresponding to the global coordinate system.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the argument is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family is not a Conceptual Mass Family. |