Gets the local coordinate system (LCS) for an analytical model element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public Transform GetLocalCoordinateSystem() |
Visual Basic |
---|
Public Function GetLocalCoordinateSystem As Transform |
Visual C++ |
---|
public: Transform^ GetLocalCoordinateSystem() |
Return Value
Transformation matrix. Returns nullNothingnullptra null reference (Nothing in Visual Basic) for analytical model elements that do not have local coordinate system. Origin returned by transform is point for which local coordinate system was calculated.
Remarks
For obtaining LCS at specified point on analytical model element use
[!:Autodesk::Revit::DB::Structure::AnalyticalModelStick::GetLocalCoordinateSystem()] or
[!:Autodesk::Revit::DB::Structure::AnalyticalModelSurface.GetLocalCoordinateSystem()] methods.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when called on Isolated Foundation, Wall Foundation or in-place analytical model element. Those elements do not support local coordinate system. |