Rename the current print setting with the specified name.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool Rename( string newName ) |
Visual Basic |
---|
Public Function Rename ( _ newName As String _ ) As Boolean |
Visual C++ |
---|
public: bool Rename( String^ newName ) |
Parameters
- newName
- Type: System..::..String
print setting name to be renamed as.
Return Value
False if Rename operation fails, otherwise true.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the input newName already exists in current print setting list. |