Retrieves an object from which mappings between parameter definitions and categories can
be found.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public BindingMap ParameterBindings { get; } |
Visual Basic |
---|
Public ReadOnly Property ParameterBindings As BindingMap Get |
Visual C++ |
---|
public: property BindingMap^ ParameterBindings { BindingMap^ get (); } |
Remarks
Returns a mapping between parameter definitions and parameter bindings. New bindings can
be added to the Revit Document by using this object.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | When the document is a family document. |