Creates a new instance of MemberForces.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2016
Syntax
C# |
---|
public MemberForces(
bool start,
XYZ force,
XYZ moment
) |
Visual Basic |
---|
Public Sub New ( _
start As Boolean, _
force As XYZ, _
moment As XYZ _
) |
Visual C++ |
---|
public:
MemberForces(
bool start,
XYZ^ force,
XYZ^ moment
) |
Parameters
- start
- Type: System..::..Boolean
Member Forces position on analytical model stick element. True for start, false for end.
- force
- Type: Autodesk.Revit.DB..::..XYZ
The Translational forces at specified position of the element.
The x value of XYZ object represents force along x-axis of the analytical model coordinate system, y along y-axis, z along z-axis respectively.
- moment
- Type: Autodesk.Revit.DB..::..XYZ
The Rotational forces at specified position of the element.
The x value of XYZ object represents moment about x-axis of the analytical model coordinate system, y about y-axis, z about z-axis respectively.
Exceptions
See Also