Gets the report content in this view.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020.1
Syntax
C# |
---|
public string GetReportContent() |
Visual Basic |
---|
Public Function GetReportContent As String |
Visual C++ |
---|
public: String^ GetReportContent() |
Return Value
The content of the report as displayed in the view, or the referenced file name.
Remarks
The report shows "Calculating..." if the background calculation is still going on.
You may call isAnalysisCompleted() to check if the calculation is completed.