The family parameter label of the dimension.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public FamilyParameter FamilyLabel { get; set; } |
Visual Basic |
---|
Public Property FamilyLabel As FamilyParameter Get Set |
Visual C++ |
---|
public: property FamilyParameter^ FamilyLabel { FamilyParameter^ get (); void set (FamilyParameter^ value); } |
Remarks
A dimension only can be labeled to a family parameter in a family document.
When the dimension is labeled by a reporting parameter, the dimension value drives the parameter value.
When the parameter is labeled by a non-reporting, the value of the parameter drives the dimension.
If the dimension is multi-segmented, each segment of the dimension is driven by the same parameter value.
Multi-segmented dimensions cannot be labeled by reporting parameters.
To unbind the family parameter, set this property to nullNothingnullptra null reference (Nothing in Visual Basic).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the family parameter's ParameterType is not suitable for this dimension. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when dimension can not be labeled. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when failed to get the BuiltInParameter DIM_LABEL. |