Creates a new Solid which is the intersection of the input Solid with the half-space on the positive side of the given Plane. The positive side of the plane is the side to which Plane.Normal points.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2016
Syntax
Visual Basic |
---|
Public Shared Function CutWithHalfSpace ( _
solid As Solid, _
plane As Plane _
) As Solid |
Visual C++ |
---|
public:
static Solid^ CutWithHalfSpace(
Solid^ solid,
Plane^ plane
) |
Return Value
The newly created Solid.
Exceptions
See Also