Fixity of translation along Z.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public AnalyticalFixityState TranslationZ { get; set; }
Visual Basic
Public Property TranslationZ As AnalyticalFixityState
	Get
	Set
Visual C++
public:
property AnalyticalFixityState TranslationZ {
	AnalyticalFixityState get ();
	void set (AnalyticalFixityState value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException When setting this property: The fixity state translationZ is not valid for Analytical Link Type parameters.
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..DisabledDisciplineException When setting this property: None of the following disciplines is enabled: Structural.

See Also