Returns the stairs path curves on the run. The curves are projected on base level of the stairs.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public CurveLoop GetStairsPath() |
Visual Basic |
---|
Public Function GetStairsPath As CurveLoop |
Visual C++ |
---|
public: CurveLoop^ GetStairsPath() |
Return Value
The stairs path curves.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | The stairs run has no stairs path it probably because the run was not generated yet. |