Sets all input diameters from diametersOptions in current RebarBarType.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018.1
Syntax
C# |
---|
public void SetBarTypeDiameters( BarTypeDiameterOptions diametersOptions ) |
Visual Basic |
---|
Public Sub SetBarTypeDiameters ( _ diametersOptions As BarTypeDiameterOptions _ ) |
Visual C++ |
---|
public: void SetBarTypeDiameters( BarTypeDiameterOptions^ diametersOptions ) |
Parameters
- diametersOptions
- Type: Autodesk.Revit.DB..::..BarTypeDiameterOptions
The input diameters are validated as follows : barDiameter is both positive and no more than the smallest value of 1.0 and the input bend diameters. Each bend diameter is smaller than 99.0 and bigger than barDiameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the diameters ranges in diametersOptions are not acceptable. |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |