The DisplayStyle of the view.
Returns DisplayStyle.Wireframe if the view has no display style.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2013
Syntax
Visual Basic |
---|
Public Property DisplayStyle As DisplayStyle
Get
Set |
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..ArgumentException |
When setting this property: DisplayStyle cannot be set to Raytrace.
Because setting a view's display style to raytrace enters a special restricted mode with limited capabilities,
it is not permitted to directly assign the display style to this value.
-or-
When setting this property: DisplayStyle cannot be set to Undefined.
-or-
When setting this property: DisplayStyle of Drafting Views can be set only to Wireframe or HLR
|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
Autodesk.Revit.Exceptions..::..InvalidOperationException |
When setting this property: DisplayStyle cannot be modified.
-or-
When setting this property: This view does not contain display-related properties.
|
See Also