Returns curve loops that define geometry of the area boundary conditions.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public IList<CurveLoop> GetLoops() |
Visual Basic |
---|
Public Function GetLoops As IList(Of CurveLoop) |
Visual C++ |
---|
public: IList<CurveLoop^>^ GetLoops() |
Return Value
The curve loop collection.
Remarks
Boundary conditions should be BoundaryConditionsType::Area type. Otherwise exception is thrown.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidObjectException | Thrown when BoundaryConditions is not a BoundaryConditionsType::Area type. |