Identifies if changing the width of an existing layer from zero to a positive value will create a rectangular region.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool CanLayerWidthBeNonZero( int layerIdx ) |
Visual Basic |
---|
Public Function CanLayerWidthBeNonZero ( _ layerIdx As Integer _ ) As Boolean |
Visual C++ |
---|
public: bool CanLayerWidthBeNonZero( int layerIdx ) |
Parameters
- layerIdx
- Type: System..::..Int32
The index of a CompoundStructureLayer.
Remarks
This is only allowed if there is a vertical line such that all regions to the left are assigned to layers with index < layerIdx,
and all regions to the right are assigned to layers with index > layerIdx.