Creates a new PropertySetElement to contain the given asset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static PropertySetElement Create( Document document, ThermalAsset thermalAsset ) |
Visual Basic |
---|
Public Shared Function Create ( _ document As Document, _ thermalAsset As ThermalAsset _ ) As PropertySetElement |
Visual C++ |
---|
public: static PropertySetElement^ Create( Document^ document, ThermalAsset^ thermalAsset ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document in which to create the PropertySetElement.
- thermalAsset
- Type: Autodesk.Revit.DB..::..ThermalAsset
The thermal asset containing the values that will be present in the PropertySetElement.
Return Value
The new PropertySetElement.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the name of the asset is empty, contains prohibited characters, or is not unique |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |