Determines if this CurveLoop is oriented counter-clockwise (CCW) or clockwise (CW) with
respect to the specified 3D direction.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public bool IsCounterclockwise( XYZ normal ) |
Visual Basic |
---|
Public Function IsCounterclockwise ( _ normal As XYZ _ ) As Boolean |
Visual C++ |
---|
public: bool IsCounterclockwise( XYZ^ normal ) |
Parameters
- normal
- Type: Autodesk.Revit.DB..::..XYZ
The normal vector to the plane used for this determination.
Return Value
True if the curve loop is oriented counter-clockwise with respect to the specified 3D direction, false if the loop is oriented clockwise.
Remarks
CCW means that the projection of the CurveLoop onto a plane having "normal" as its oriented normal is CCW.
This method should only be called if the loop is closed and has a non-singular projection onto the plane
(i.e., the projection should have no self-intersections and should not be degenerate or even
nearly degenerate). The return value in other cases is indeterminate.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The curve loop is open or consists of a single unbound curve; counterclockwise determination has no meaning. |