Creates a new diameter dimension object using the default dimension type.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Dimension NewDiameterDimension( View view, Reference arcRef, XYZ origin ) |
Visual Basic |
---|
Public Function NewDiameterDimension ( _ view As View, _ arcRef As Reference, _ origin As XYZ _ ) As Dimension |
Visual C++ |
---|
public: Dimension^ NewDiameterDimension( View^ view, Reference^ arcRef, XYZ^ origin ) |
Parameters
- view
- Type: Autodesk.Revit.DB..::..View
The view in which the dimension is to be visible.
- arcRef
- Type: Autodesk.Revit.DB..::..Reference
Geometric reference of the arc to which the dimension is to be bound.
- origin
- Type: Autodesk.Revit.DB..::..XYZ
The point where the witness line of the diameter dimension will lie.
Return Value
If creation was successful the new diameter dimension is returned, otherwise an exception with failure information will be thrown.
Remarks
The currently user set default style is used for the created dimension.
Remarks
The dimension will be created on default place.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when any input argument is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the argument arcRef is invalid. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the creation failed. |