Allows clients to poll the cancellation status of a background operation. Revit instantiates
CancellationListener objects for internal background operation implementations only. As such,
third-party developers are not expected to instantiate or handle CancellationListener objects.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public class CancellationListener : IDisposable |
Visual Basic |
---|
Public Class CancellationListener _ Implements IDisposable |
Visual C++ |
---|
public ref class CancellationListener : IDisposable |
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..CancellationListener
Autodesk.Revit.DB..::..CancellationListener