Negates the specified vector and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public static XYZ operator -(
	XYZ source
)
Visual Basic
Public Shared Operator - ( _
	source As XYZ _
) As XYZ
Visual C++
public:
static XYZ^ operator -(
	XYZ^ source
)

Parameters

source
Type: Autodesk.Revit.DB..::..XYZ

Return Value

The vector opposite to the specified vector.

Remarks

The negated vector is obtained by changing the sign of each coordinate of the specified vector.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException Thrown when source is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also