Indicates whether to enable analysis for closed loop hydronic piping networks.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public bool AnalysisForClosedLoopHydronicPipingNetworks { get; set; } |
Visual Basic |
---|
Public Property AnalysisForClosedLoopHydronicPipingNetworks As Boolean Get Set |
Visual C++ |
---|
public: property bool AnalysisForClosedLoopHydronicPipingNetworks { bool get (); void set (bool value); } |
Remarks
For closed loop hydronic piping networks, Revit can analyze flow and pressure values for supply and return loops. In the model, select a pump to see the results of the analysis in the Properties palette.
A closed loop hydronic piping network must contain:
A single pump/circulatorA single source, such as a boilerMultiple piping segmentsMultiple terminals, such as radiators.A network may contain a direct return loop or a reverse return loop.