Test the category id to make sure the category is allowed for a DirectShape or DirectShapeType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2015
Syntax
Visual Basic |
---|
Public Shared Function IsValidCategoryId ( _
categoryId As ElementId, _
doc As Document _
) As Boolean |
Visual C++ |
---|
public:
static bool IsValidCategoryId(
ElementId^ categoryId,
Document^ doc
) |
Return Value
True if the category is allowed for a DirectShape or DirectShapeType, false if not.
Exceptions
See Also