Searches this and all nested LinkLoadResults, and returns a list
of ExternalResourceReferences for the links that failed to load.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public IList<ExternalResourceReference> GetExternalResourceReferencesFromFailedLoads() |
Visual Basic |
---|
Public Function GetExternalResourceReferencesFromFailedLoads As IList(Of ExternalResourceReference) |
Visual C++ |
---|
public: IList<ExternalResourceReference^>^ GetExternalResourceReferencesFromFailedLoads() |
Return Value
A collection of link ExternalResourceReferences which failed to load.
Remarks
In cases, where a nested structure of several links were loaded, this method is intended to be a convenient way for IExternalResourceUIServers to determine whether a top-level link, or any sub-link, which failed to load properly was provided by their IExternalResourceServer or another server.
If this link and all nested links loaded successfully, then an empty list is returned.