Deletes all FailureMessages of severity "Warning" currently posted in a document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public void DeleteAllWarnings() |
Visual Basic |
---|
Public Sub DeleteAllWarnings |
Visual C++ |
---|
public: void DeleteAllWarnings() |
Remarks
Warnings are deleted immediately and will not be accessible by any further failures processing.
Any accessors for these failure messages become invalid.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). |