Indicates whether the input element is arrayable.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static bool IsElementArrayable( Document aDoc, ElementId id ) |
Visual Basic |
---|
Public Shared Function IsElementArrayable ( _ aDoc As Document, _ id As ElementId _ ) As Boolean |
Visual C++ |
---|
public: static bool IsElementArrayable( Document^ aDoc, ElementId^ id ) |
Parameters
- aDoc
- Type: Autodesk.Revit.DB..::..Document
The document.
- id
- Type: Autodesk.Revit.DB..::..ElementId
The element id.
Return Value
True if the input element is arrayable, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |